Koduleht on nii turvaline kui seda on paigaldatud sisuhaldustarkvara versioon. Kui ilmunud parandusi ning turvaparandusi ei paigaldata võimalikult kiiresti siis on oht, et koduleht pahategijate poolt kahjustatakse.

Meie saame aidata Joomlal baseeruvate kodulehtede uuendamisel. Täpsema info saate telefonil +372 557 3501 või e-posti aadressil .

 

Joomla uuendamine versioonilt 1.0.x versioonile 3.x

Juhul kui on paigaldatud kolmanda osapoole lisakoponente, mille arendamisest on loobutud, siis on vaja leida sama funktsionaalsusega komponent ning sellele andmed üle viia. Samuti on täielikult muutunud mitmekeelsuse osa. Joomla 1.0 ja 1.5 seerial on mitmekeelsed lehed lahendatud kolmanda osapoole komponentide kaudu (JoomFish) aga alates Joomla 1.7 (2.5) versioonist on Joomlasse mitmekeelsuse funktsionaalsus sisse ehitatud. Seetõttu erineb ka mitmekeelsete lehtede struktuur oluliselt. 1.0 seeria Joomlas pole kasutusel ka UTF-8 kodeeringut, mis eesti keele puhul nõuab ka sisu kooditabelite konverteerimist. Vastasel korral kuvatakse täpitähed vigaselt.

Joomla 1.0 versioonide tugi on lõppenud. Kui Teie koduleht kasutab seda versiooni, siis tuleb see viivitamatult uuendada 3.x versioonile.

 

Joomla uuendamine versioonilt 1.5.x versioonile 3.x

On veidi kergem kui 1.0 versiooni uuendamine. Siiski tuleb uuendus teha spetsialistidel, sest Joomla 1.5 uuendamine nõuab eriteadmisi ning ajakulu vältimiseks ka spetsiaaltarkvara olemasolu.

Joomla 1.5 versioonide tugi on lõppenud. Kui Teie koduleht kasutab seda versiooni, siis tuleb see viivitamatult uuendada 3.x versioonile.

 

Joomla uuendamine versioonilt 2.5.x versioonile 3.x

Joomla 2.5 tugi lõppes 31.12.2014. Joomla baasi uuendamine ei ole probleemne kuid 3-da osapoole komponentide, kujunduste ning pistikprogrammide uuendamine võib olla keeruline ning mõnikord ka võimatu. Meie pakume abi Joomla kaasaajastamisel, lisatarkvara uuendamisel ning vajadusel alternatiivsete lahenduste väljatöötamisel ja teostamisel.

Joomla 2.5 versioonide tugi on lõppenud. Kui Teie koduleht kasutab seda versiooni, siis tuleb see viivitamatult uuendada vähemalt 3.x versioonile.